High Performance Essentials
Greengage Consulting Limited
0.0.3 Varies with device
Full use of this App requires an approved account.

This app provides tools that will help us all to work together to get results.
When understood and consistently applied, the tools in this App have the capacity to transform the way we work and to create an environment where the ideas of staff are taken on board and that they are left in no doubt that the patient comes first.

* Organise your thoughts around any project or breakthrough using the Three Rs
Start here if you: Want to make a breakthrough,
Have a problem that you aren't clear how to tackle,
Want to create a compelling strategic narrative,
Want to get your message clear about a change that you will be making.

* Engage the ideas and expertise of your colleagues using the engaged leaders checklist
Start here if you: Need the co-operation of colleagues to make your work a success,
Need buy-in from colleagues to a change you want to make,
Want to turn resistance into forward momentum for change.

* Build trust and improve communication using authentic speech and stand in my shoes
Start here if you need to: Plan a difficult but important conversation,
Say difficult things or give critical feedback,
Resolve conflict or disagreement between colleagues,
Understand why people don’t agree on how to move things forward.

* Make sure your meetings are an engine of change using PPADDA
Start here if you: Plan breakthrough events and engagement workshops,
Need to make sure plans get implemented,
Want to maintain momentum and overcome obstacles,
Make sure time in meetings is time well spent.

* Use must-do performance agreements to make sure what has been agreed happens
Start here if you: Need to create a culture of focus and follow through in your team or organisation,
Want to prevent colleagues feeling overwhelmed and that everything is a priority,
Want to drive delivery of key tasks and objectives,
Need to align individual and team activity with corporate objectives.

Content rating: Everyone

Requires OS: 2.3.3 and up

...more ...less