Check Point Protect
Check Point Software Technologies, Ltd.
2.51.0-187 Varies with device
Check Point Protect helps organizations mitigate security risks when allowing employees to use their own (BYOD) smartphones and tablets at work. It offers the industry’s most comprehensive mobile protection for Android devices, applications and data.
Protect keeps information stored and accessed on mobile devices safe, all without impacting user experience or privacy. It helps you stay productive by keeping you connected to enterprise applications and data, and it gives you the confidence of knowing your personal information and company’s assets are protected from advanced, targeted mobile cyber threats like
- Viruses and malware that can steam information on or flowing through your device
- Spyware that criminals can use to snoop on what you say and do on your device. Spyware can be used to access your email, location, or even to take over your device’s microphone or camera.
- Wi-Fi hotspot intrusions that hackers can use to steal information sent and received on your device when you connect in a public place like an airport or coffee shop.
- Advanced persistent threats (APTs) that use a variety of vectors over time to learn as much about you, the resources you connect to, and the data you access.
Protect is a lightweight app that runs in the background, so it won’t impact your device’s battery life or performance. And there’s nothing you need to learn and nothing you need to do. If a threat is detected, intuitive prompts let you know exactly what’s happened and exactly what you need to do to keep your data safe. This gives you the freedom to use your device as you always have without the fear of an attacker or corporate eyes spying on your sensitive information.
Check Point Software Technologies is committed to protecting your privacy. We don't collect or share any personal information with anyone. For more information, please see the privacy statement on our site at http://www.checkpoint.com/privacy.

Content rating: Everyone

Requires OS: 4.0 and up

...more ...less