***IMPORTANT NOTE: This app is for UNFI customers who are unable to install iUNFI 3.0 because they are unable to quickly update to iOS 6. Updating iOS is recommended and easy in most cases, but we understand some customers are pushing into an ordering deadline. Upgrade to iOS 6 at your earliest convienence and become compatible with iUNFI 3.0. The features and stability improvements are well worth it!

Content rating: Rated 4+

Requires OS: 4.3

Supported Devices:
- iPad
- iPhone
- iPod Touch

...more ...less