Parrots
F0RIS
1.6.4 Varies with device
This app don't have english content yet! If you have time, know russian, like this app, and wanna share this content to english speakers, write me to f0risw@gmail.com

Content rating: Everyone

Requires OS: 2.3 and up

...more ...less