FRENCH-GREEK LEGAL DICTIONARY
Nomiki Bibliothiki Group S.A.
1.2 Varies with device
The French-Greek & Greek-French Dictionary of Legal Terms, edited by Nomiki Bibliothiki is the most complete, accurate and easy-to-use dictionary of legal terms, an instant landmark in Greek legal lexicography. Renowned for its comprehensive coverage, it offers speedy access to more than 50,000 terms, guiding phrases and useful examples, and also indicative legislation in order to help the user grasp the issue at hand. The dictionary is published under the auspices of the French Institute of Greece.

In this application you can easily search for any term as results appear highlighted in yellow. You can also browse the full list of terms from A to Z in both languages French and Greek.

NOMIKI BIBLIOTHIKI SA, the leader legal publishing group in Greece, provides a modern state of the art application of the acclaimed French-Greek & Greek-French Dictionary of Legal Terms, now available for iPhone/iPad/iPod touch.

Editor-in-chief
Dr. Theodore Fortsakis, Professor of the National and Kapodistrian University of Athens

Managing editor
Dr. Claire Spirou, Collaborator at the Hellenic Institute of International and Foreign Law

Authors
- Dr. Emmanuel Gardounis, Attorney at law
- Dr. M. Kavvatha, Attorney at law
- Filia Kiranoudi, Attorney at law, D.E.A.
- Naya Pappa, Jurist, D.E.A.. LL.M.
- Dr. Konstantinos Tsimaras, Attorney at law

Features
- French-Greek & Greek-French Legal terminology
- 50.000 legal terms (including the most common latin legal terms)
- Guiding phrases-examples for better use of the legal terms
- Selected legislation for the most important legal terms
- Off-line complete - no internet connection required
- Free updates with new and updating terms until the next official edition

To activate and use the French-Greek & Greek-French Legal Dictionary you need to purchase a serial number from the following url.

http://www.nb.org/ΕΚΔΟΣΕΙΣ/ΓΑΛΛΟΕΛΛΗΝΙΚΟ_ΕΛΛΗΝΟΓΑΛΛΙΚΟ_ΛΕΞΙΚΟ_ΝΟΜΙΚΩΝ_ΟΡΩΝ_ΓΙΑ_ANDROID

Content rating: Everyone

Requires OS: 2.3 and up

...more ...less