Modesti's Car Care Center
ModestisApp
1.47.92.253 Varies with device
At Modesti's our TOP priority is our customers' satisfaction and safety. Fixing cars is how we make that happen. No surprises, no short-cuts, no kidding!

Modesti's Car Care Center has been providing premium quality maintenance and auto repair services to the Los Angeles area for over 42 years.

Our AAA-approved shop has cutting-edge auto service experience. From a standard oil change to brake repair, transmission service, electrical system work, or smog repair, you can trust our ASE Certified Master Technicians to provide you with comprehensive service on any of your repair and maintenance needs.

Our expert team is experienced at working on all years, makes and models of domestic and import automobiles, and hybrid cards. We even specialize in Audi, BMW and Mercedes repair!

Modesti's is so confident in our service and repair that we back our work with a 3 year/36,000 mile nationwide warranty and offer convenient financing options.

Our goal is, and has always been, 100% customer satisfaction. We believe in continuing education for our technicians in order to achieve that goal. We never compromise our integrity in parts, or service, or in any other way.

A Modesti's we firmly believe that honesty is the best policy so you can feel confident leaving your vehicle in our hands.

We have worked hard to create an inviting, home-like environment at our shop where you will feel welcome and comfortable. Our convenient (and free) shuttle service will get you where you need to go in the local area. You’ll enjoy complimentary gourmet coffee, as well as a free wi-fi connection so you’ll never miss a beat!

Simply stop by, give us a call, or easily schedule your auto service online at our website - www.modestis.com - and get ready to experience the difference at Modesti's Car Care Center!

In this app you can find:
About Us, Appointments, Contact, Map, Coupons, Loyalty Rewards, Win a Prize, Photos, Video, Facebook, Twitter, Instagram

Content rating: Everyone

Requires OS: 4.0 and up

...more ...less